Investigating service degradation — Composer 2.5

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted Jun 17, 2026 - 10:20 UTC

Monitoring

A fix has been implemented, stability has improved significantly and we are monitoring.
Posted Jun 17, 2026 - 10:15 UTC

Investigating

We are investigating an elevated error rate for composer 2.5 fast, which may affect other services, such as bugbot
Posted Jun 17, 2026 - 09:28 UTC
This incident affected: Bugbot and IDE.