Cursor Forum - Major Outage

Incident Report for Cursor

Resolved

The forum is now back online, apologies for any inconvenience!
Posted Mar 28, 2025 - 20:27 UTC

Update

We are continuing to investigate this issue.
Posted Mar 28, 2025 - 19:43 UTC

Investigating

Due to ongoing denial-of-service attacks, the Cursor forum (forum.cursor.com) is currently unavailable.
While we work to resolve this, please keep up to date with this status page (status.cursor.com) for more information.
Posted Mar 28, 2025 - 19:33 UTC
This incident affected: Cursor Forum (forum.cursor.com.