Slack integration degradation

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted Mar 05, 2026 - 20:48 UTC

Monitoring

Slack has implemented a fix and we are seeing signs of recovery. We are continuing to monitor the situation.
Posted Mar 05, 2026 - 20:37 UTC

Update

We believe this degradation is related to an upstream Slack integration issue. We’re working with Slack on mitigations and will provide updates. You can follow the upstream status page at https://slack-status.com/2026-03/e63ca9cc0d76539c
Posted Mar 05, 2026 - 19:16 UTC

Identified

We are discussing with the upstream integration provider to identify the root cause.
Posted Mar 05, 2026 - 19:02 UTC

Investigating

We are investigating reports of `@Cursor` from Slack not triggering Cloud Agents.
Posted Mar 05, 2026 - 18:36 UTC
This incident affected: Cloud Agent (Slack Integration).