Composer 2.5 Fast degradation

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted May 27, 2026 - 20:12 UTC

Monitoring

A fix has been implemented and Composer 2.5 Fast service has stabilized. We are monitoring for service restoration.
Posted May 27, 2026 - 18:13 UTC

Update

We are continuing to investigate this issue. We will provide updates as more information becomes available.
Posted May 27, 2026 - 16:12 UTC

Investigating

We're seeing a degradation of behaviour for Composer 2.5 Fast, we are investigating.
Posted May 27, 2026 - 15:38 UTC
This incident affected: IDE.