BugBot and Background Agent Service Degradation due to GitHub Outage

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted Aug 05, 2025 - 16:50 UTC

Monitoring

Due to a GitHub service outage, some BugBot / Background Agent functionality may be temporarily unavailable.
Once the outage is resolved, all services should resume normal operations shortly after.

https://www.githubstatus.com/
Posted Aug 05, 2025 - 15:45 UTC

Investigating

We are investigating elevated error rates for BugBot and Background Agent.
Posted Aug 05, 2025 - 15:40 UTC
This incident affected: GitHub Integrations (BugBot).