Cloud Agents degradation due to GitHub outage

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted Mar 03, 2026 - 20:04 UTC

Identified

GitHub is experiencing an outage, with downstream impact on Cloud Agents.
Notably, some Cloud Agents are failing to start because of upstream errors while cloning repositories from GitHub.

More information can be found on the GitHub status page: https://www.githubstatus.com/
Posted Mar 03, 2026 - 19:42 UTC
This incident affected: Cloud Agent (Infrastructure, Slack Integration).