BugBot + Background Agent Service Degradation

Incident Report for Cursor

Resolved

GitHub and Anthropic services are returning to normal function.
BugBot and Background Agent should be fully functional.
Posted Jul 21, 2025 - 10:03 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jul 21, 2025 - 09:59 UTC

Identified

BugBot and Background Agent runs are failing due to multiple issues with upstream providers, including GitHub and Anthropic. We are working with upstream providers to restore full service as soon as possible.
Posted Jul 21, 2025 - 07:46 UTC

Investigating

We are investigating this issue.
Posted Jul 21, 2025 - 07:44 UTC
This incident affected: Background Agent (Infrastructure) and GitHub Integrations (BugBot).