Degraded Behavior for MCP Allowlist & Blocklist Features on 3.0

Incident Report for Cursor

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 02, 2026 - 19:58 UTC

Investigating

We are investigating this issue.
Posted Apr 02, 2026 - 18:53 UTC
This incident affects: Cursor App (Chat - Agent Mode).