Investigating service degradation

Incident Report for Cursor

Resolved

This incident has been resolved at 6pm Eastern.
Posted Sep 15, 2026 - 22:00 UTC

Update

A fix has been implemented and we are monitoring for service restoration. Only Grok 4.6 (non-fast) is affected in Cursor.
Posted Sep 15, 2026 - 21:41 UTC

Monitoring

A fix has been implemented and we are monitoring for service restoration.
Posted Sep 15, 2026 - 21:38 UTC

Investigating

We are investigating a service degradation. Affected agent surfaces: Composer and xAI.
Posted Sep 15, 2026 - 21:26 UTC
This incident affected: Automations, Review Agents, CLI, Cloud Agents, IDE, Origin, and Grok Bot.