Service Degradation with Dashboard and Checkout

Incident Report for Cursor

Resolved

The service degredation regarding Stripe-related services, such as the Cursor dashboard and checkout functionality, is now resolved.
For any further billing / checkout issues, please contact the team via hi@cursor.com
Posted Oct 15, 2025 - 18:47 UTC

Investigating

We are currently seeing high error rates for dashboard and checkout functionality in Cursor.
If you are seeing errors purchasing a Cursor plan, please try again soon.
Posted Oct 15, 2025 - 18:40 UTC