Service Degradation due to Cloudflare Outage

Incident Report for Cursor

Monitoring

We are experiencing service degradation affecting Authentication and other services due to an ongoing Cloudflare issue.
Normal function will resume automatically once Cloudflare's issue is resolved.
https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 13:28 UTC

Investigating

We are investigating this issue.
Posted Nov 18, 2025 - 13:16 UTC