Stripe Payment Syncing Issues

Incident Report for Cursor

Resolved

Stripe syncing should now be resolved, and accounts should be up to date shortly.
Posted Feb 25, 2025 - 19:48 UTC

Monitoring

Due to a spike in subscriptions and usage, we are currently seeing some issues with syncing subscription purchases to your accounts.

As such, if you have recently purchased a subscription with us, you may not see your account update immediately. Please allow up to 30 minutes for your account to sync during this period of high usage, but we hope this will resolve soon.
Posted Feb 25, 2025 - 16:50 UTC
This incident affected: Cursor App (Chat - Agent & Custom Modes) and User Dashboard (cursor.com).