Investigating service degradation — Cloud Agents

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted Jun 09, 2026 - 01:31 UTC

Investigating

We are investigating reports of elevated error rates for Cloud Agents.
Posted Jun 08, 2026 - 23:43 UTC
This incident affected: Cloud Agents.