Investigating service degradation — Automations, Cloud Agents, and IDE

Incident Report for Cursor

Investigating

We are investigating degraded performance for requests that use Composer 2.5. Users may see failed or retried requests in Automations, Cloud Agents, and the IDE when Composer 2.5 is used. Other models are unaffected.
Posted Aug 12, 2026 - 01:39 UTC
This incident affects: Automations, Cloud Agents, and IDE.