Investigating Service Degradation

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted May 08, 2026 - 02:14 UTC

Monitoring

A fix has been implemented and we are monitoring for service restoration.
Posted May 08, 2026 - 01:37 UTC

Update

We are currently investigating instability for the "auto" model provider.
Posted May 08, 2026 - 01:19 UTC

Update

We are continuing to investigate this issue.
Posted May 08, 2026 - 00:45 UTC

Investigating

We are investigating a service degradation.
Posted May 08, 2026 - 00:43 UTC
This incident affected: Automations, CLI, Cloud Agents, and IDE.