Grok Bot connector delays

Incident Report for Cursor

Update

We are continuing to investigate an issue causing some Grok Bot connectors to hang. We are working to restore normal operation.
Posted Aug 18, 2026 - 19:29 UTC

Investigating

We’re investigating an issue causing Grok Bot connectors to hang. We’ll share updates as we learn more.
Posted Aug 18, 2026 - 18:46 UTC
This incident affects: Grok Bot.