Gemini 2.5 - Performance Degredation

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted Apr 24, 2025 - 06:11 UTC

Investigating

Some users are currently experiencing performance issues with the Gemini 2.5 models.
We are actively collaborating with Google to identify the root cause and are working to resolve this as quickly as possible.
https://forum.cursor.com/t/gemini-2-5-issues-looping-bad-performance-wrong-language-etc/82427
Posted Apr 23, 2025 - 10:13 UTC