Service Degradation

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted Mar 06, 2026 - 09:16 UTC

Investigating

We are investigating this issue.
Posted Mar 06, 2026 - 08:47 UTC