DNS Connectivity Issues Impacting Background Agent

Incident Report for Cursor

Resolved

The upstream issue with Cloudflare DNS has been resolved.
Posted Jul 15, 2025 - 01:38 UTC

Update

The upstream issue with Cloudflare DNS has been resolved.
Posted Jul 15, 2025 - 01:37 UTC

Investigating

We are investigating this issue.
Posted Jul 14, 2025 - 22:05 UTC