Degraded Performance for Agent Sessions

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted Jun 02, 2026 - 18:42 UTC

Monitoring

We identified that Composer 2.5 was the only impacted model. A fix has been implemented and we are monitoring for service restoration.
Posted Jun 02, 2026 - 18:41 UTC

Investigating

We are investigating a service degradation affecting CLI, Cloud Agents, and IDE.
Posted Jun 02, 2026 - 18:02 UTC
This incident affected: CLI, Cloud Agents, and IDE.