Partial Service Degradation for Background Agents (GitHub Integration)

Incident Report for Cursor

Resolved

Background Agents on Web, and it's related GitHub features, should now be fully accessible again.
Posted Jun 30, 2025 - 20:52 UTC

Update

We are currently experiencing instability issues with GitHub related to our Background Agents functionality.
The issue has been identified, and we are working with the team at GitHub to implement a fix.
We hope to be able to re-enable Background Agent on Web shortly.
Posted Jun 30, 2025 - 19:57 UTC

Identified

We are currently seeing instability issues with GitHub with our Background Agents functionality.
While the team continue to investigate, please retry any failed GitHub-related events in a few minutes.
Posted Jun 30, 2025 - 17:00 UTC

Investigating

We are currently seeing an increased rate of GitHub integration errors, mainly affected Background Agents functionality.
The team have been notified and are investigating.
Posted Jun 30, 2025 - 15:30 UTC
This incident affected: Background Agent (Infrastructure).