Investigating service degradation — Cloud Agents

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted Jul 27, 2026 - 19:39 UTC

Monitoring

Automations are back to normal, and cloud agent start failures have subsided. We're monitoring closely to confirm full recovery.
Posted Jul 27, 2026 - 18:46 UTC

Identified

Some Cursor Automations may fail to start, and running Automations may be unable to post replies in Slack or open pull requests. We've identified the causes and fixes are rolling out.
Posted Jul 27, 2026 - 17:41 UTC

Investigating

We are investigating a service degradation affecting Cloud Agents.
Posted Jul 27, 2026 - 17:09 UTC
This incident affected: Cloud Agents.