Service Degradation

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted Mar 21, 2026 - 03:41 UTC

Monitoring

We continue to see service degradation for some users. We have identified what triggered the degradation and are working to gradually recover all services and functionality prioritizing agent workloads.
Posted Mar 21, 2026 - 00:36 UTC

Investigating

We are investigating this issue.
Posted Mar 20, 2026 - 23:37 UTC