Investigating service degradation - Sol

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted Jul 14, 2026 - 20:10 UTC

Investigating

This incident is now resolved.
Posted Jul 14, 2026 - 20:05 UTC
This incident affected: IDE.