Ongoing Service Degradation

Incident Report for Cursor

Resolved

We have now implemented a mitigation for this issue, and all services should be back to standard operation.
We apologise for any inconvenience caused during this brief period of degradation.
Posted 2 months ago. Jun 19, 2025 - 08:50 UTC

Identified

The cause of the issue has been identified, and the team is implementing a mitigation to restore services to normal execution.
Posted 2 months ago. Jun 19, 2025 - 08:41 UTC

Investigating

We're currently investigating a technical issue affecting Cursor's databases, which is leading to degraded performance and reduced availability for some services and in-app features. The team is actively investigating the issue, and we will provide an update soon.
Posted 2 months ago. Jun 19, 2025 - 08:02 UTC
This incident affected: Cursor App (Chat - Agent & Custom Modes) and Website (User Dashboard (cursor.com)).