Investigating service outage

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted Jun 10, 2026 - 19:46 UTC

Update

A fix has been implemented and we are monitoring for service restoration.
Posted Jun 10, 2026 - 19:45 UTC

Update

A fix has been implemented, and we are monitoring for service restoration.
Posted Jun 10, 2026 - 19:26 UTC

Monitoring

A fix has been implemented, and we are monitoring for service restoration.
Posted Jun 10, 2026 - 19:25 UTC

Identified

We have identified the issue and are actively working on resolution.
Posted Jun 10, 2026 - 19:23 UTC

Investigating

Cursor has received wide spread issue reports. We are actively investigating.
Posted Jun 10, 2026 - 19:09 UTC
This incident affected: Automations, Bugbot, CLI, Cloud Agents, cursor.com, and IDE.