Degraded Performance for Composer 2.5

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted Jun 17, 2026 - 17:19 UTC

Update

We are currently investigating this issue. We will provide updates as more information becomes available.
Posted Jun 17, 2026 - 17:04 UTC

Investigating

Degraded Performance for Composer 2.5
Posted Jun 17, 2026 - 16:29 UTC
This incident affected: CLI, Cloud Agents, and IDE.