Investigating service degradation

Incident Report for Cursor

Monitoring

A fix has been implemented and we are monitoring for service restoration.
Posted Aug 18, 2026 - 11:02 UTC

Investigating

We are investigating an issue preventing users from removing members from teams.
Posted Aug 18, 2026 - 10:38 UTC
This incident affects: cursor.com.