MCP authentication failures in Automations and Cloud Agents

Incident Report for Cursor

Identified

The root cause has been identified and a fix is being implemented.
Posted Aug 07, 2026 - 16:04 UTC

Investigating

We are investigating an issue where users are unable to authenticate with MCP servers in Automations and Cloud Agents. Affected runs may fail to connect to their MCP tools.
Posted Aug 07, 2026 - 15:53 UTC
This incident affects: Automations and Cloud Agents.