Background Agents Not Making Progress

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted Aug 04, 2025 - 21:41 UTC

Monitoring

We have implemented a fix and are monitoring the results.
Posted Aug 04, 2025 - 21:10 UTC

Identified

We're investigating reports of background agents unable to perform file edits and seeming stuck.
Posted Aug 04, 2025 - 20:48 UTC
This incident affected: Background Agent (Infrastructure).