Service Degradation due to AWS Outage

Incident Report for Cursor

Resolved

Cursor services appear to be resolved, with reliability back to normal levels.
The team will continue to monitor for any further degredation, but all Cursor services should be fully functional.
Posted Oct 20, 2025 - 09:37 UTC

Investigating

We are seeing an increased rate of errors following a series of system outages and service degredation with AWS.
The team are monitoring closely, and systems should self-recover once the downtime is resolved.
Posted Oct 20, 2025 - 07:25 UTC