Database load issues resulting in incorrectly rejected requests

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted Jul 04, 2025 - 20:28 UTC

Update

We are continuing to investigate this issue.
Posted Jul 04, 2025 - 20:28 UTC

Update

We are continuing to investigate this issue.
Posted Jul 04, 2025 - 20:21 UTC

Update

We are continuing to investigate this issue.
Posted Jul 04, 2025 - 20:17 UTC

Update

We are continuing to investigate this issue.
Posted Jul 04, 2025 - 20:16 UTC

Investigating

We are currently investigating a database proxy issue that is partially degrading Cursor.
Posted Jul 04, 2025 - 20:16 UTC
This incident affected: Cursor App (Chat - Agent & Custom Modes) and Website (User Dashboard (cursor.com)).