Cursor Forum - Planned Maintenance

Incident Report for Cursor

Resolved

Work is now complete, and the forum is now back to full functionality.
Posted Apr 21, 2025 - 23:07 UTC

Monitoring

To help keep the forum stable and responsive, the Forum is currently read-only while we work on necessary improvements.
We hope to have this resolved soon and the forum back to full functionality shortly.
Posted Apr 21, 2025 - 22:02 UTC
This incident affected: Cursor Forum (forum.cursor.com.