We have implemented a fix for Chat, Tab and Codebase Indexing and are monitoring the results.
We are still working to restore service for Background Agents.
Posted Oct 27, 2025 - 21:53 UTC
Monitoring
We have implemented a fix and are seeing recovery across services.
Posted Oct 27, 2025 - 21:52 UTC
Update
We are currently seeing significant service disruptions affecting login, AI chat, Cloud agents, and other core features. Our team continues to implement a fix and will provide an update as progress is made.
Posted Oct 27, 2025 - 21:34 UTC
Update
We are currently seeing significant service disruptions affecting login, AI chat, Cloud agents, and other core features. Our team is actively investigating and working to restore full functionality as quickly as possible.
Posted Oct 27, 2025 - 20:53 UTC
Update
We are currently seeing significant service disruptions affecting login, AI chat, Cloud agents, and other core features. Our team is actively investigating and working to restore full functionality as quickly as possible.
Posted Oct 27, 2025 - 20:04 UTC
Update
We are currently seeing significant service disruptions affecting login, AI chat, and other core features. The team has identified the issue and is working on a fix.
Posted Oct 27, 2025 - 19:57 UTC
Identified
We are currently seeing significant service disruptions affecting login, AI chat, and other core features. Our team is actively investigating and working to restore full functionality as quickly as possible.
Posted Oct 27, 2025 - 19:53 UTC
Update
The team are continuing to investigate this issue, and will update this incident page shortly.
Posted Oct 27, 2025 - 18:46 UTC
Investigating
We are currently investigating elevated error rates for login, dashboard and repository indexing.
Posted Oct 27, 2025 - 18:21 UTC
This incident affects: Cursor App (Chat - Agent & Custom Modes, Tab, Codebase Indexing) and Background Agent (Infrastructure, Slack Integration).