Investigating service degradation

Incident Report for Cursor

Investigating

We are investigating a service degradation. Some users may experience occasional low rate errors when using grok 4.5 models.
Posted Jul 14, 2026 - 19:52 UTC
This incident affects: IDE.