Inaccurate or Missing Usage Data on Dashboard

Incident Report for Cursor

Resolved

The team has deployed a fix and all services have been restored to normal functionality.
Posted Aug 02, 2025 - 06:50 UTC

Investigating

We are investigating an issue where the cursor.com site is showing inaccurate usage data.
Posted Aug 01, 2025 - 23:21 UTC