Missing Analytics Data due to Service Degradation

Incident Report for Cursor

Monitoring

We have begun to backfill missing data - analytics data should continue to restore and be fully available shortly.
This incident will be closed once we have confirmed all data is restored.
Posted Sep 04, 2025 - 09:31 UTC

Investigating

We are investigating a degradation in Cursor Analytics. Some metrics may be underreported for the time being
Posted Sep 03, 2025 - 20:15 UTC