Degraded Performance for Agent Sessions

Incident Report for Cursor

Monitoring

A fix has been implemented and we are monitoring for service restoration.
Posted May 26, 2026 - 03:47 UTC

Investigating

We are monitoring a service degradation affecting Agents sessions in IDE
Posted May 26, 2026 - 03:04 UTC
This incident affects: IDE.