Gemini Models - Major Degradation

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted May 12, 2025 - 10:29 UTC

Monitoring

Google are working to resolve this issue.
Once the capacity issue is resolved by Google, they will be available again in Cursor shortly.
Posted May 12, 2025 - 06:59 UTC

Investigating

Due to significant degradation with Google, the Gemini models currently have very low availability.
Once the capacity issue is resolved by Google, they will be available again in Cursor shortly.
We apologise for any inconvenience during this time.
Posted May 12, 2025 - 06:50 UTC
This incident affected: Cursor App (Chat - Agent & Custom Modes).