Investigating service degradation

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted Jul 20, 2026 - 02:19 UTC

Investigating

We are investigating a service degradation of Cursor Grok 4.5, Cursor Grok 4.5 Fast, and Auto.
Posted Jul 20, 2026 - 02:00 UTC
This incident affected: Automations, CLI, Cloud Agents, and IDE.