Investigating Grok 4.5 degradation

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 09:36 UTC

Monitoring

A fix has been implemented and we are monitoring for service restoration.
Posted Jul 16, 2026 - 09:34 UTC

Update

Investigation is ongoing for degradation of Grok 4.5. Users should switch to Auto or try another model while we work toward a resolution.
Posted Jul 16, 2026 - 07:50 UTC

Update

We are continuing to work on the Grok 4.5 degradation. Please switch to Auto or try another model.
Posted Jul 16, 2026 - 07:35 UTC

Update

We are continuing to investigate this issue. We will provide updates as more information becomes available.
Posted Jul 16, 2026 - 07:22 UTC

Investigating

We are investigating partial degradation of Grok 4.5. Users should switch to Auto or try another model.
Posted Jul 16, 2026 - 07:01 UTC
This incident affected: Automations, Bugbot, CLI, Cloud Agents, cursor.com, and IDE.