Degraded agent performance on Composer 2.5 / Auto requests

Incident Report for Cursor

Monitoring

A fix has been implemented and we are monitoring for service restoration.
Posted May 21, 2026 - 14:59 UTC

Identified

The root cause has been identified and a fix is being implemented.
Posted May 21, 2026 - 14:58 UTC

Investigating

We are investigating a service degradation affecting Composer 2.5 / Auto requests.
Posted May 21, 2026 - 12:25 UTC
This incident affects: CLI and IDE.