Service Degradation with Agent Chat

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted Nov 25, 2025 - 22:22 UTC

Investigating

We are receiving reports of service degradation with Cursor's Chat functionality.
The team are investigating, and a further update will be posted shortly.
Posted Nov 25, 2025 - 12:10 UTC