Degraded Performance for Agent Sessions

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted May 05, 2026 - 17:41 UTC

Monitoring

A fix has been implemented and we are monitoring for service restoration.
Posted May 05, 2026 - 16:32 UTC

Investigating

We are investigating a service degradation affecting IDE, Cloud Agents, and CLI. Affected agent surfaces: Composer.
Posted May 05, 2026 - 16:28 UTC
This incident affected: Automations, CLI, Cloud Agents, and IDE.