Investigating service degradation

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted Jul 15, 2026 - 11:32 UTC

Monitoring

A fix has been implemented and we are monitoring for service restoration.
Posted Jul 15, 2026 - 10:58 UTC

Investigating

We are investigating a service degradation affecting Grok 4.5
Posted Jul 15, 2026 - 08:52 UTC
This incident affected: Automations, CLI, Cloud Agents, and IDE.