GCP Outage - Degradation with Indexing and Authentication

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 21:00 UTC

Update

The incident is fully resolved.
Posted Jun 12, 2025 - 20:32 UTC

Update

Authentication functionality, including sign up, login, and https://www.cursor.com/dashboard access, is restored.
Posted Jun 12, 2025 - 20:08 UTC

Update

We are continuing to monitor for any further issues.
Posted Jun 12, 2025 - 20:05 UTC

Update

Due to an ongoing outage with GCP, some of Cursor's features and services are currently degraded, including indexing, authentication, and model availability.
While we are waiting for a resolution, we recommend using the "Auto" or OpenAI models.

https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW
Posted Jun 12, 2025 - 18:20 UTC

Monitoring

Due to an ongoing outage with GCP, some of Cursor's features and services, including indexing and authentication, are currently degraded.
While we are monitoring this, these systems should restore on their own once the outage is resolved.
Posted Jun 12, 2025 - 18:18 UTC

Investigating

We are investigating this issue.
Posted Jun 12, 2025 - 18:15 UTC
This incident affected: Cursor App (Chat - Agent & Custom Modes, Codebase Indexing) and User Dashboard (cursor.com).