Incorrect Usage Amount on Dashboard

Incident Report for Cursor

Resolved

This incident has been resolved. Usage should display correctly in the dashboard.
Posted Jul 08, 2026 - 14:58 UTC

Investigating

We are investigating a service degradation affecting cursor.com, causing usage to incorrectly display as 0%
Posted Jul 08, 2026 - 14:28 UTC
This incident affected: cursor.com.