Investigating service degradation — cursor.com, Automations, and Cloud Agents

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted Jul 28, 2026 - 18:24 UTC

Monitoring

A fix has been implemented and we are monitoring for service restoration.
Posted Jul 28, 2026 - 18:21 UTC

Investigating

We are investigating a service degradation affecting cursor.com, Automations, and Cloud Agents.
Posted Jul 28, 2026 - 18:19 UTC
This incident affected: Automations, Cloud Agents, and cursor.com.