Degraded Services

Incident Report for Cursor

Resolved

The infrastructure issues are now resolved, and Cursor services should be returning to normal shortly.
Posted Mar 28, 2025 - 05:33 UTC

Update

We are continuing to monitor system performance, and working to recover our infrastructure to full capacity.
Posted Mar 28, 2025 - 05:25 UTC

Update

System recovery is still in progress, and some services are now becoming available.
The team is closely monitoring this, and is working to resolve any further issues.
Posted Mar 28, 2025 - 03:40 UTC

Monitoring

A fix has been implemented, and services should start to recover shortly.
Posted Mar 28, 2025 - 03:34 UTC

Identified

Due to a database deployment issue within Cursor's infrastructure, Cursor is seeing degradation across all its features.
This may affect most AI features, including Chat and Tab.
The cause is known, and a fix is being worked on.
Posted Mar 28, 2025 - 03:20 UTC
This incident affected: Cursor App (Chat, Tab).