Investigating service degradation

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted Jul 20, 2026 - 12:23 UTC

Monitoring

Service has stabilized across the affected surfaces, and we are actively monitoring performance.
Posted Jul 20, 2026 - 03:46 UTC

Investigating

We are investigating a service degradation. Affected agent surfaces: Composer, Cursor Grok 4.5, and Auto.
Posted Jul 20, 2026 - 02:54 UTC
This incident affected: Automations, CLI, Cloud Agents, and IDE.